概述 7月中后旬,我们一直在推进 Base 链发布的相关活动 1. Base is for builders,一款免费的创世 NFT 活动,需要签名特定消息获取,可使用我们的官方 Blocklet 获取 https://www.nftstudio.rocks/base is for builders/ https://www.nftstudio.rocks/base is for builders/ 2. Genesis Builder NFT,需要在 Base 链部署合约,并且满足一定条件填写表单,后续能获得不同等级的 NFT 这个活动有一定的门槛,需要部署合约并且校验合约,对新手不太友好
Support
Describe your issue, share reproduction steps, and find answers together.
Guidelines
Community guidelines
Be kind and constructive. Share your experience, choose a category, and include enough detail to help others.
Useful links
ArcBlock documentationMy discussionsSearch discussionsNewest discussions
如图,根据给出的url无法访问 ! image.png https://media.arcblock.community/blocklets/discuss kit/media/bafkreify3hseu7hrxltf452sjreey63a6dn4fd4kyddskeb74kx7daxvt4.webp
目前 Blocklet Server @blocklet/cli 对 Windows 的支持不是很好,在使用 Blocklet Server 或 开发 Blocklet 过程中可能会遇到一些问题,比如: 从 Blocklet Store 安装、运行 Blocklet 会报路径错误 执行 dev 相关的 blocklet 命令可能会遇到问题 我个人之前尝试过一种方案,可以在 Windows 上比较顺畅的使用 Blocklet Server 或者进行 Blocklet 的开发,这套方案主要使用了虚拟机和 VSCode Remote Development,下面我大概描述一下这套环境的搭建。 说明:
! image.png https://media.arcblock.community/blocklets/discuss kit/media/bafkreid3rhkclluuzyk6fjbwgvcx3tbry53vrqshhs27y5afraqjjjuxhm.webp
问题1: 使用静态网页模板,按照命令指示,最后在blocklet dev报错 ! image.png https://media.arcblock.community/blocklets/discuss kit/media/bafkreibbtwcgiicnnqbk7qshcejio4kuoogsnae6hsk3shrrkyhlwoatnm.png 问题2:使用了vue3+express , 成功启动后,最后按照给出的url访问404 ! image.png https://media.arcblock.community/blocklets/discuss kit/media/bafkrei
目前window启动blocklet server正常,安装任何一个基石程序都会报错文件不存在 例如 \E:\arcblock\.blocklet server\tmp\download\static demo blocklet\static demo blocklet 1.3.0.tgz does not exist 看起来应该是没去兼容window的路径,给路径前面加了 \ 导致找不到文件 ! image.png https://media.arcblock.community/blocklets/discuss kit/media/bafkreidnr4dwef4dam2u63plfmj
目前国内云服务器基本无法使用,启动后基本会遇到这两种情况: 1. 启动过程中会跳转到类似于 bbqathu4gax677pjl6kdwmtr22sjwqhy3skxpfx3274.did.abtnet.io/ ,但是無法連上這個網站 2. 跳转成功的话提示域名需要备案 整个启动流程的问题应该是出现在问题1中网址域名,ping了一下该域名最后是指向我的云服务ip,将问题1地址直接改为我ip访问后是跳转到仪表盘页面,显然不是理想中的效果,那应该是blocklet中会去对二级域名(bbqathu4gax677pjl6kdwmtr22sjwqhy3skxpfx3274.did.abtnet.io)进行
背景: 访问blocklet出现节点服务节点的连接已经断开,可能是出现了网络异常或者节点服务节点故障,如下图: ! https://blog.yaoch.top/upload/image.png ! https://community.arcblockio.cn/upload/image.png 解决思路: 1. 用f12观察请求,应该是有个ws:// /admin/websocket的请求不通; 2. 怀疑是否云服务器出入站策略拦截,上网查询websocket属于TCP协议,不应该被拦截; 3. 怀疑nginx问题,毕竟一开始没出现该问题,用ip访问果然不会出现,应该是nginx需要配置we
场景: 有台云服务器,创建blocklet后,第一次打开需要绑定DID,就用了手机DID钱包绑定了,晚上回家到,用电脑谷歌插件钱包,想要登录,却提示没有管理员权限那个NFT, 两个端的助记词是一样的,账号应该是一样的
如下图,Discuss Kit 服务启动失败,试了另外一个blocklet运行成功,应该不是本地原因吧 ! image.png https://media.arcblock.community/blocklets/discuss kit/media/bafkreiatmnefbpyljj34rkexbxwulm7nfwu64xk7b7hr73z63qmwrhtfpe.webp ! image.png https://media.arcblock.community/blocklets/discuss kit/media/bafkreibqmpd6s3dx2jklk7kqy7bjxpnaos6u
! image.png https://media.arcblock.community/blocklets/discuss kit/media/bafkreihbqw2tbzro5htwagxi6ynndzrxz6f2pm2j45bcoxs4pojufex7ie.webp
1. 按照官方的命令行: docker run d p 80:80 p 443:443 v <your host directory :/data ghcr.io/arcblock/blocklet server 启动后报权限问题, 需要docker的run命令行加上 privileged=true u=root 后可解决 ! image.png https://media.arcblock.community/blocklets/discuss kit/media/bafkreie62t4w73xq2sybpilkn7dailrflua3s4dwxim2lyh5naws74mjzi.webp
! image.png https://media.arcblock.community/blocklets/discuss kit/media/bafkreifkdnrirsjxm7ashgvnaecfng746cayzc43cijqxfsulrdeowxwi4.webp ! image.png https://media.arcblock.community/blocklets/discuss kit/media/bafkreiguquasltxndhhz6vzwjagdfbvg6bg4at3rd5a2vrhyk3tmhj7swm.webp DIDspace有之前免费送的1g空间
如图 ! image.png https://media.arcblock.community/blocklets/discuss kit/media/bafkreiguffllqggcie4x44pdibo4dikeyjtnlls5wau2eu5mnuppvcwz2y.webp ! image.png https://media.arcblock.community/blocklets/discuss kit/media/bafkreifx4p2juemggda3eiekww4kvq5nhh4ie7mdc6wtzrifcsy6rosua4.webp
! image.png https://media.arcblock.community/blocklets/discuss kit/media/bafkreicbrw7pdg2dyrydhrp3glxjrpeptqtxmvc7nrmlzchfuiu34zi2hi.webp ! image.png https://media.arcblock.community/blocklets/discuss kit/media/bafkreicbrw7pdg2dyrydhrp3glxjrpeptqtxmvc7nrmlzchfuiu34zi2hi.webp http://bbqauvqtgxbwo4ahv
! image.png https://media.arcblock.community/blocklets/discuss kit/media/bafkreibgdxew2fanqxtufhq42q4xnuieph6azfs4clikjqtvtqqz44eyty.webp 链接:http://static demo blocklet mav 121 37 15 113.ip.abtnet.io:8001/?serverUrl=http%3A%2F%2F121.37.15.113%3A8001%2Fadmin%2F& start =1
docker run p 10000:10000 v /tmp/docker abtnode:/Users/data/arcblock env ABT NODE DOMAIN=192.168.1.7 env ABT NODE PORT=10000 arcblock/abtnode 返回错误信息: WARNING: The requested image's platform linux/amd64 does not match the detected host platform linux/arm64/v8 and no specific platform was requested ⚠ @